A grande richiesta finalmente ho trovato un pò di tempo per scrivere una guida riguardo all’installazione di Compiz-Fusion.
Prima di seguire questa guida è neccessario avere gia installato il driver della scheda video.
Per istruzioni a riguardo guardare Installazione driver nvidia su ubuntu 7.04 Feisty Fawn.

Allora per prima cosa aggiungiamo repository del grande Trevino.
Andiamo sul terminale e digitiamo:

sudo gedit /etc/apt/sources.list

Successivamente aggiungiamo questo al file:

# Treviño’s Ubuntu Deisty EyeCandy Repository (GPG key: 81836EBF)
# Many eyecandy 3D apps: Beryl, Compiz, Fusion, AWN and kiba-dock
# built using latest available (working) sources from git/svn/cvs…
deb http://download.tuxfamily.org/3v1deb feisty eyecandy
deb-src http://download.tuxfamily.org/3v1deb feisty eyecandy

Dovrebbe venire una cosa del genere:

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://it.archive.ubuntu.com/ubuntu/ feisty main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ feisty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://it.archive.ubuntu.com/ubuntu/ feisty-updates main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ feisty-updates main restricted

# Treviño’s Ubuntu Deisty EyeCandy Repository (GPG key: 81836EBF)
# Many eyecandy 3D apps: Beryl, Compiz, Fusion, AWN and kiba-dock
# built using latest available (working) sources from git/svn/cvs…
deb http://download.tuxfamily.org/3v1deb feisty eyecandy
deb-src http://download.tuxfamily.org/3v1deb feisty eyecandy

[……..]

Adesso ci serve la chiave GPG:

wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add -

Non resta che aggiornare i repository:

sudo apt-get update

ed installare compiz-fusion:

sudo apt-get install compiz-fusion-plugins-main

sudo apt-get install compiz-fusion-plugins-extra

sudo apt-get install compiz-fusion-plugins-unsupported

sudo apt-get install compizconfig-settings-manager

Per poter avviare Compiz-Fusion automaticamente basta andare in Sistema > Preferenze > Sessioni > New ed aggiungere come nome Compiz-Fusion e come comando compiz –replace.
Attenzione al comando compiz –replace, perchè la formatazione di wordpress lo scrive male.
Al posto di bisogna mettere due trattini.

Non resta che riavviare il computer e godervi i nuovi effetti di Compiz-Fusion. Potete anche personalizzarli come volete voi con il configuratore che trovate in Sistema > Preferenze > CompizConfig.

Spero di esservi stato d’aiuto.;-)

Annunci

29 Responses to “Installazione Compiz-Fusion Su Ubuntu”


  1. 1 marco
    giugno 29, 2007 alle 10:44 am

    scusate ma…come funzionerà con kde4 che integrerà Kwin composite? Voglio dire..ci sarà modo di passare da kwin a compiz-fusion in modo agile?

  2. 3 KuKi
    agosto 26, 2007 alle 11:40 am

    scusa b2jj..ma cm mai..tutti i comandi il mio terminale gli esegue bene..e qnd vado amettere l’ultimo omando..m dice ke è impossibile..o ke è errato????????????please..aiutami

  3. agosto 29, 2007 alle 12:18 pm

    Che comando ti dà errore?

  4. 5 Christian
    settembre 21, 2007 alle 1:06 pm

    ottima guida davvero! l’ho installato senza problemi e funziona benissimo!
    solo una domanda…mi sai dire come posso fare in modo che quando cambio faccia del cubo esso si allontana e mi permette di vederlo girare da lontano?

  5. 6 azuele
    settembre 27, 2007 alle 5:53 pm

    scusate ma quando digitate wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add – non vi da nessun problema??? A me si blocco finche non schicci ctrl+C la shell è bloccata.

    posto l’errore
    wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add –
    –19:47:54– http://download.tuxfamily.org/3v1deb/DD800CD9.gpg
    => `-‘
    Risoluzione di download.tuxfamily.org in corso… Password:88.191.250.18
    Connessione a download.tuxfamily.org|88.191.250.18:80… connesso.
    HTTP richiesta inviata, aspetto la risposta… 200 OK
    Lunghezza: 4,180 (4.1K) [application/octet-stream]

    100%[====================================>] 4,180 21.26K/s

    19:47:55 (21.19 KB/s) – “-” salvato [4180/4180]

    sudo: pam_authenticate: Conversation error

  6. 7 newbill
    ottobre 1, 2007 alle 4:55 pm

    a me tutti i comandi danno errori 😦

  7. 8 dave
    ottobre 2, 2007 alle 6:33 pm

    Ho installato tutto con successo.
    Riavvio, ma niente cubo.
    Ho controllato le impostazioni da Sistema –> Preferenze –>CompizConfig che sia tutto abilitato.
    Ma niente da fare. E’ come se non avessi installato nulla…

  8. 9 route24
    ottobre 3, 2007 alle 7:56 pm

    Ho installato ubuntu 7.04 su virtualbox, il problema è che ubuntu non mi riconosce la scheda grafica (mobile intel 945gm express chipset family) anche dopo aver installato i driver da intellinux.org, non posso usare compiz fusion. se qualcuno puo aiutarmi….

  9. 10 m10
    ottobre 11, 2007 alle 5:11 pm

    @route24 c’e un problema noto per cui dopo un aggiornamento delle librerie glx compiz non funziona piu’ cerca un po’ su launchpad e ubuntuforums …(non ricoro bene dove l’ho letto)
    @Kuki se é il comado compiz [trattino][trattino]replace assicurati di mettere 2 trattini (sostituisci a [trattino] – ) 🙂

  10. 11 paolo
    ottobre 21, 2007 alle 7:26 pm

    ma sto procedimento funge su skede ati?

  11. ottobre 24, 2007 alle 4:10 pm

    mmm.. mi dice sudo: gedit: command not found

  12. 13 dario
    novembre 22, 2007 alle 2:55 pm

    alby Ottobre 24, 2007 alle 4:10 pm

    mmm.. mi dice sudo: gedit: command not found

    mi sa che devi fare prima

    sudo apt-get install gedit

    poi prova..

  13. 14 dario
    novembre 22, 2007 alle 3:02 pm

    scusatemi, qualcuno mi sa dire perchè con compiz-fusion su ubuntu Gutsy (i386, nvidia) non mi permette di vedere il terminale? mi da una schermata bianca al posto della finestra.. poi mi fa lo stesso effetto con le notifiche nella trybar.. e cosa più importante non mi fa vedere le barre dei menu..

    vi prego aiutatemi.

    ho installato la stessa versione di ubuntu (per i386) su un portatile con un amd 64 X2 e video ATI, poi ho installato manualmente compiz per le ati e li funziona tutto benissimo.. non capisco perchè a questo computer non debba andare!

  14. 15 `Noname
    marzo 7, 2008 alle 9:49 pm

    Di problemi Compiz-Fusion per Ubuntu ne da’ soltanto se non settate il file: /etc/X11/xorg.conf;
    ci sono dei parametri da aggiungere e da togliere vi lascio il listato di operazioni da svolgere: solamente-(per schede NVIDIA):

    nella sezione “Module”, assicuratevi che siano presenti i seguenti moduli e nel caso aggiungeteli:

    Load “dbe”
    Load “glx”

    sempre nella sezione “Module”, assicuratevi che non siano presenti i moduli “GLCore” e “dri” e nel caso eliminateli o commentateli anteponendo un #

    – nella sezione “Device” assicuratevi di sostituire “nv” o “vesa” con “nvidia” nella riga “Driver” in questo modo:

    Driver “nvidia”

    – infine, se presente, eliminate la sezione “DRI” in fondo al file e sostituitela con:

    Section “Extensions”
    Option “Composite” “Enable”
    EndSection

    Finito, tutto il necessario è installato e configurato perfettamente, e non rimane altro da fare che testare l’installazione. Riavviate la vostra Ubuntu e se tutto è andato a buon fine, prima della schermata di login visualizzerete lo splash screen nvidia.

    Potrete inoltre verificare la corretta installazione dei driver proprietari NVIDIA sulla vostra Ubuntu digitando:

    cat /proc/driver/nvidia/version

    che dovrebbe restituirvi:

    NVRM version: NVIDIA Linux x86 Kernel Module 71.86.01 / 96.43.01 / 169.07

    nella sezione “Module”, assicuratevi che siano presenti i seguenti moduli e che non siano commentati da un # ad esclusione di “dri” (che deve avere il simbolo # davanti a Load)

    Load “dri”
    Load “dbe”
    Load “glx”

    sempre nella sezione “Module”, assicuratevi che non sia presente “GLCore” e nel caso eliminatelo o commentatelo con #

    sempre nella sezione “Device”, per NVIDIA è necessario aggiungere le seguenti opzioni:

    Option “AllowGLXWithComposite” “True”
    Option “AddARGBGLXVisuals” “True”
    Option “TripleBuffer” “True”
    Option “RenderAccel” “True”

    – infine, controllate che non ci sia la sezione “DRI” in fondo al file, e assicuratevi invece che sia presente la sezione “Extensions”, e che Composite sia abilitato:

    Section “Extensions”
    Option “Composite” “Enable”
    Option “RENDER” “True”
    Option “DAMAGE” “True”
    EndSection

  15. marzo 25, 2008 alle 11:29 am

    Quando inserisco il comando: wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add –

    Mi risponde:
    wget: opzione non valida — 0
    gpg: non sono stati trovati dati OpenPGP validi.

    Si puo sapere cos’è successo?

    Ringrazio in anticipo.

  16. 17 andrea
    marzo 29, 2008 alle 11:22 am

    io ho due problemi…il primo è che se lancio compizconfig setting manager non appare nulla…e gia questo è un bel problema… il secondo che credo sia collegato al primo è che se digito da terminale compiz vedo questo:

    Checking for Xgl: present.
    Checking for nVidia: not present.
    Checking for Xgl: present.
    Enabling Xgl with nVidia drivers…
    Starting gtk-window-decorator
    /usr/bin/compiz.real (cube) – Warn: Failed to load slide: freedesktop

    help me!!! che devo fare?

  17. 18 Sir_Wilson
    aprile 16, 2008 alle 4:06 pm

    Ma dove posso trovare Compiz-Fusion???
    Sn nuovo di Ubuntu non sn tanto agile ad usarlo.

  18. 19 ghost
    agosto 31, 2008 alle 10:11 pm

    Spacchetto compiz-fusion-plugins-unsupported (da …/compiz-fusion-plugins-unsupported_0.5.2~git20071006+3v1ubuntu0_i386.de b) …
    dpkg: errore processando /var/cache/apt/archives/compiz-fusion-plugins-unsupported_0.5.2~git20071006+3v1ubuntu0_i386.deb (- -unpack):
    tentata sovrascrittura di `/usr/share/compiz/3d.xml’, che si trova anche nel pacchetto compiz-fusion-plugins-extra
    dpkg-deb: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)
    Sono occorsi degli errori processando:
    /var/cache/apt/archives/compiz-fusion-plugins-unsupported_0.5.2~git20071006+3v1ubuntu0_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    AIUTOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

  19. 20 daniele
    novembre 21, 2008 alle 11:24 am

    ciao ,rahazzi…ma vedo tutti sti comandi da linea di comando…tutti ste procedure…driver da linea di comando…ma che è dos? ma nel 2009 ancora co ste linee di comando? ho capito che è roba da smanettoni, ma…mma mia! cmq neanche io riesco a installarlo…

  20. 21 Paz
    dicembre 4, 2008 alle 11:31 am

    @Daniele sei liberissimo di usare Winzozz, se preferisci non sapere niente di quello che stai facendo, e divertirti a guardare le schermate blu…molto pittoresche..

  21. giugno 9, 2009 alle 11:24 am

    a me sembrava di aver postato il mio problema come mai non appare?

  22. giugno 9, 2009 alle 11:29 am

    Ora vedo che posta…quindi magari …
    avevo gia seguito questa procedura in un altro pc ed era andato tutto a buon fine…
    ieri sera volevo rifarla su un’altro pc…e…
    root@fabio-desktop:~# wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add –
    –2009-06-09 13:26:23– http://download.tuxfamily.org/3v1deb/DD800CD9.gpg
    Risoluzione di download.tuxfamily.org… 88.191.250.18
    Connessione a download.tuxfamily.org|88.191.250.18|:80…

    si blocca

  23. 24 andry........
    dicembre 4, 2009 alle 5:54 pm

    è bellisimoooooooooooooooooo l’ho provato è geniale sono mito…………..

  24. luglio 18, 2010 alle 1:42 pm

    ciao a tutti min chiamo anna ciao ciao

  25. luglio 18, 2010 alle 1:43 pm

    hola son la vera laura esquivel hola

  26. luglio 28, 2013 alle 6:51 am

    Great article! That is the kind of information that
    are supposed to be shared across the web.
    Shame on Google for not positioning this put up upper!

    Come on over and consult with my website . Thanks =)

  27. 28 Ale
    novembre 20, 2013 alle 9:32 am

    Sconsiglio vivamente questa guida. Una volta eseguita la prima install da terminale, mi ha rimosso tutti i pacchetti base di ubuntu, compreso il software center.


Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...




novembre: 2017
L M M G V S D
« Ago    
 12345
6789101112
13141516171819
20212223242526
27282930  

Archivi


%d blogger hanno fatto clic su Mi Piace per questo: